Centos versione mysql è 5.5 tuttavia PHPmyadmin dice ancora versione 5.1

Quando eseguo le seguenti operazioni nella mia console:

[root@****~]# mysql -u root -p -e 'SELECT VERSION();' Enter password: +-----------+ | VERSION() | +-----------+ | 5.5.39 | +-----------+ 

Quale dovrebbe essere la versione corretta.

Tuttavia, quando inserisco il mio PHPMYADMIN sul mio server, sono le seguenti specifiche:

 Server: Localhost via UNIX socket Program: MySQL Programversion: 5.1.73 - Source distribution 

Quindi quale versione è quella corretta e come faccio ad assicurarmi che il database sia in esecuzione su 5.5?

Nota

Ho già riavviato sql diverse volte senza modifiche

One Solution collect form web for “Centos versione mysql è 5.5 tuttavia PHPmyadmin dice ancora versione 5.1”

Il tuo mysqld è sicuramente in esecuzione MySQL 5.5.39

per assicurarsi di correre

 mysqld --version | awk '{print $3}' 

PHPMyadmin potrebbe essere utilizzando un client 5.1.73

È anche ansible accedere a mysql dalla row di command e eseguire questa operazione

 mysql> status 

Otterrai un'output simile a questa

 /usr/bin/mysql Ver 14.14 Distrib 5.5.30, for Linux (x86_64) using readline 5.1 Connection id: 723 Current database: mydb Current user: root@localhost SSL: Not in use Current pager: stdout Using outfile: '...' Using delimiter: ; Server version: 5.5.30-log MySQL Community Server (GPL) Protocol version: 10 Connection: Localhost via UNIX socket Server characterset: utf8 Db characterset: utf8 Client characterset: utf8 Conn. characterset: utf8 UNIX socket: /var/lib/mysql/mysql.sock Uptime: 10 hours 40 min 45 sec Threads: 5 Questions: 820429 Slow queries: 79 Opens: 4376 Flush tables: 3 ... 

Vedrai la linea

 Server version: 5.5.30-log MySQL Community Server (GPL) 

È la versione del server che conta.

La row 1 ha la versione client.

  • Se dice 5.1.73, basta installare il client 5.5.39 e rimuovere il client 5.1.73.
  • Se dice 5.5.39 e PHPMyAdmin insiste ancora che sia 5.1.73, si possono avere due client installati e PHPMyAdmin utilizza ostinatamente quello vecchio. Basta disinstallare il client 5.1.73.
Suggerimenti per Linux e Windows Server, quali Ubuntu, Centos, Apache, Nginx, Debian e argomenti di rete.