Cercando di installare l'estensione pecl Solr, ma ha bisogno di arricciarsi

Quando provo a installare solr-beta:

pecl installa solr-beta

Ottengo questo errore:

pecl / solr richiede l'estensione PHP "curl" Nessun pacchetto valido trovato l'installazione non è rioutput

La cosa è che la curl è già installata e sembra essere abilitata quando guardo la mia pagina di phpinfo.

  • Perché il pannello di amministrazione di solr non viene mostrato?
  • Come posso installare daemon in una casella CentOS?
  • Come aumentare la lunghezza massima della query HTTP GET consentita in Jetty?
  • Può un account RAID 1 di Linux per un'elevata latenza?
  • Come determinare quando SOLR inizia la creazione di un indice
  • Come monitorare SOLR
  • Che cos'è un contenitore Servlet e come installarlo?
  • ricarica del solr core senza riavviare il tomcat
  • One Solution collect form web for “Cercando di installare l'estensione pecl Solr, ma ha bisogno di arricciarsi”

    Da quanto accennato in http://pecl.php.net/bugs/bug.php?id=17012&edit=1 , pecl non riconosce i moduli php che non sono stati staticamente compilati in php. Quindi, se si utilizzano librerie condivise, pecl li ignorerà.

    Pecl ignora anche il tuo php.ini.

    La buona notizia è che ci sono ancora due semplici modi per installare questo se si dispone di curl come un'estensione condivisa:

    1) pear installare pecl / solr

    2) installare pecl -n solr

    Questo dovrebbe installare il module php solr. Dovrai includere la libreria solr.so modificando il file php.ini.

    Suggerimenti per Linux e Windows Server, quali Ubuntu, Centos, Apache, Nginx, Debian e argomenti di rete.