Come faccio a evitare l'avviso "già utilizzato da un altro lavoratore" in un Apache2 inverso proxy config?

Ho aggiunto le corrispondenze di server corrispondenti ProxyPass e ProxyPassReverse, ma sono stato "già utilizzato da un altro lavoratore" [avvisi] messaggi all'avvio.

Ho una soluzione proposta che è abbastanza buona per me, visto che sembra aver eliminato i messaggi e mi ha fatto quasi dimenticare questo problema. Questa soluzione è quella di mettere le voci in ordine inverso per caso nel file di configuration.

Penso che il vero problema abbia a che fare con l'espressione corrispondente, poiché se "Videos" è stato elencato prima di "Videos2", vi è stato un avviso. Una volta che ho invertito queste voci, le avvertenze si arrestarono.

  • Il block server Nginx non viene selezionato
  • Nginx vs Apache come proxy inverso, quale scegliere
  • Qual è il modo corretto per consentire l'accesso a un sito IIS attraverso un proxy inverso?
  • Alcuni configuratori di proxy di nginx inversa fanno funzionare una volta al giorno
  • nginx reindirizza indietro a remote_addr IP
  • Come funziona il proxy nginx websocket?
  • IIS6 siti web multipli SSL in un singolo sito HTTP?
  • proxy di inversione nginx tutte le richieste a due server a monte?
  • 3 Solutions collect form web for “Come faccio a evitare l'avviso "già utilizzato da un altro lavoratore" in un Apache2 inverso proxy config?”

    Mi rendo conto che questo è un vecchio post, ma dato che è venuto in una ricerca di google che stavo facendo ho pensato che avrei pubblicato alcune informazioni utili che ho trovato riguardo questo stesso errore.

    In alcuni casi questo messaggio di errore è benigno. Ad esempio, stavo ottenendo in CentOS 5, ma il config del proxy era perfettamente legittimo e funzionava bene. Puoi vedere la discussione relativa a questo problema: https://issues.apache.org/bugzilla/show_bug.cgi?id=44350

    e notare che il suggerimento di spostarlo in un errore di livello "debug" anziché un errore di livello "avviso" è stato implementato nelle versioni più recenti di mod_proxy: https://issues.apache.org/bugzilla/show_bug.cgi?id= 48947

    Spero che questo aiuti chiunque anche alla ricerca di questo errore su internet!

    Come hai scoperto, devi prima specificare le partite più specifiche.

    Secondo l'bugzilla di Apache questo dovrebbe essere fissato in 2.2.16, vedere https://issues.apache.org/bugzilla/show_bug.cgi?id=48947

    Suggerimenti per Linux e Windows Server, quali Ubuntu, Centos, Apache, Nginx, Debian e argomenti di rete.