Come risolvere "Repository spostato permanentemente su"? utilizzando VisualSVN / Subversion

Sto utilizzando Visual SVN su un server.

Installazione fresca. Creare un nuovo repository. Provare a connettersi utilizzando un client

si esce con "Repository spostato in modo permanente a ' https: // xxxx: 6443 / '; si prega di trasferire"

Ho una sensazione che ha a che fare con l'indirizzo IP che i client utilizzano per la connessione non è la stessa di quella in cui il server è in esecuzione? non sono sicuro.

  • Cosa succede durante l'applicazione delle impostazioni del computer
  • Evento IO di disco ansible
  • Devo installare tutti i driver di printing possibili per i client RDP?
  • Compressione HTTP in IIS 6.0 (Windows Server 2003)
  • Autenticazione IIS Kerberos
  • Distribuzione di file utilizzando una politica di gruppo in Windows Server 2003
  • Impostare IIS per richiedere la window di nome utente / password invece di utilizzare un module?
  • Caricare i server IIS bilanciati con session InProc di ASP.NET
  • 5 Solutions collect form web for “Come risolvere "Repository spostato permanentemente su"? utilizzando VisualSVN / Subversion”

    Questo messaggio significa che stai utilizzando un URL di repository non valido. URL di repository server VisualSVN sembra http: // servername / svn / repos / path . Ti consiglio di utilizzare il command URL di copia in VisualSVN Server Manager per get l'URL corretto.

    Scopri se questo ti aiuta a risolvere questo problema.

    http://subversion.tigris.org/faq.html#http-301-error

    provare a utilizzare l'opzione svn per passare all'indirizzo IP.

    FYI: Ho avuto questo errore quando avevo definito un alias per consentire l'elenco dei repository:

    Alias /svn "/var/svn/repos" <Location /svn/> SVNParentPath /var/svn/repos SNVListParentPath on .... </Location> 

    Senza gli Alias, vorrei get "non trovato" quando si naviga su / svn, mentre / svn / functionrebbe.

    Quindi sembra che una correzione per un bug ha causato un altro!

    Questo problema è discusso nel link Critical Skill pubblicato.

    Ho avuto lo stesso problema. Provare a cambiare SVNParentPath in SVNPath nel file httpd.conf . Questa è la mia configuration:

     <Location /svn> DAV svn SVNPath C:\svn_repository\proj1 </Location> 

    e funziona bene.

    Sto controllando le differenze tra SVNPath e SVNParentPath .

    Suggerimenti per Linux e Windows Server, quali Ubuntu, Centos, Apache, Nginx, Debian e argomenti di rete.