Devo aspettarmi problemi con una versione diversa dell'estensione PHP MySQL rispetto al server MySQL?

Ho un server che ha una versione di PHP MySQL versione 5.0.77 mentre la versione MySQL è 5.1.34. Alcuni pezzi di software / script mi ​​avvertono che posso avere problemi.

Quali problemi dovrei aspettarmi e dovrei preoccuparmi? (Non sto eseguendo richieste / comandi MySQL in PHP). È un grosso problema?

Non abbiamo voglia di ricomprimere PHP con una versione più recente della libreria e l'amministratore del server non aveva idea di come (anche se probabilmente avrei potuto capire).

One Solution collect form web for “Devo aspettarmi problemi con una versione diversa dell'estensione PHP MySQL rispetto al server MySQL?”

Il tipo di problema che sarei preoccupato in quella situazione – supponendo che un test superficiale mostrava che ero alless in grado di eseguire alcune query di base – sono le differenze nella gestione di casi angoli oscuri nel protocollo applicativo. Cioè, il tipo di cosa in cui si corre bene per un mese e poi qualche idiosincrasia del comportmento della networking solletica il problema e le cose si fanno strano. Solo perché non fai niente di speciale con MySQL non significa che sei sicuro. Potrebbe essere che nulla avrebbe sbagliato, ma certamente non mi sentirei sicuri di correre con quella disallineamento.

Se lo provate, dovresti provare a organizzare in modo che qualcos'altro o qualcuno ti ricordi che questo è il caso se si inizia ad avere vizi di applicazione strano.

Suggerimenti per Linux e Windows Server, quali Ubuntu, Centos, Apache, Nginx, Debian e argomenti di rete.