i caricatori a nastro su Centos 6 entrano in fiamme di attività all'avvio, all'avviamento di udev

Ho due robot a nastro (Quantum Superloader 3), uno con connettività SCSI parallela, l'altra con SAS. Sono stati connessi ad un server Centos 5 e l'avvio avrebbe proceduto normalmente.

Ora sono connessi a un nuovo server che esegue CentOS 6.3. Quando il server arriva alla fase 'Start udev', uno dopo l'altro, i commutatori iniziano a passare attraverso molte routine, presumibilmente una sorta di inventario. Il commutatore SAS va innanzitutto, probabilmente perché viene assegnato un numero di dispositivo inferiore (/ dev / changer-sg4 rispetto al / dev / changer-sg6 dell'altro changer). Mentre questo sta accadendo, il process di avvio rimane solo su 'Avvio di udev'

Il primo cambio scorre attraverso il suo inventario in circa 3-4 minuti, quindi inizia il secondo cambio. A pochi minuti, vedo che i messaggi di errore SCSI vengono visualizzati sullo schermo (posso incollarli qui presto se sono necessari), ma il cambia continua a fare il suo inventario e il caricamento inizia correttamente da lì. Il caricatore finisce prima dell'avvio e quando avviene il caricamento del sistema, entrambi i cambi di nastro sembrano essere completamente disponibili e funzionanti.

Il risultato è che il process di avvio è stato completato senza intervento manuale, ma vorrei tagliare il tempo supplementare che stava aggiungendo all'avvio e l'usura supplementare sui caricatori di nastro (se esiste).

  • regole di udev in ubuntu
  • Riconoscimento coerente di 10 gbps su Dell Host
  • /lib/udev/net.agent che causa un elevato utilizzo della CPU
  • Come posso fare Linux eseguire uno script bash quando un disco specifico è hotswapped dentro?
  • posizione di 70-persistenti-net.rules in Centos 7
  • Automount ATA / SCSI unità con systemd
  • Perché il mio eth0 è chiamato eno16777736?
  • Creazione di etichette di unità persistenti con UDEV Utilizzo di / dev / disk / by-path
  • One Solution collect form web for “i caricatori a nastro su Centos 6 entrano in fiamme di attività all'avvio, all'avviamento di udev”

    Rispondere alla tua modifica.

    Non credo che questo sia importnte. Solo perché qualcosa ha funzionato un certo modo in EL5 non significa che dovrebbe essere previsto di comportrsi in modo simile in EL6.

    Devi considerare:

    • Generazioni differenti del kernel …
    • Molti difetti compilati in modo diverso.
    • Le impostazioni di sysctl.conf sono diverse.
    • I file di configuration del pacchetto / applicazione sono diversi …

    Probabilmente è il process di caricamento / initialization del sottosistema SCSI. Non credo che questo provocherà l'usura prematura del vostro disco. Dubito che ci sia un modo per aggirare il process …

    Non dovresti caricare / scaricare i moduli o riavviare abbastanza spesso per essere un problema.

    Suggerimenti per Linux e Windows Server, quali Ubuntu, Centos, Apache, Nginx, Debian e argomenti di rete.