Installazione di Foreman su istanza amazon ec2

Ciao a tutti e grazie per aver letto,

Attualmente sto installando un servizio di fantoccio per le nostre istanze ec2 e ho deciso di provare un responsabile (la gestione del certificato di nodes e l'installazione automatica dei passeggeri sembrano piacevoli).

Purtroppo sono in difficoltà con l'installazione. Sono fresco un 'Amazon Linux AMI x86_64 PV':

[root@hostname ~]# uname -a Linux hostname 3.10.35-43.137.amzn1.x86_64 #1 SMP Wed Apr 2 09:36:59 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux 

e ha provato quanto segue:

 sudo yum -y update sudo yum -y install http://yum.theforeman.org/releases/1.1/el6/x86_64/foreman-release.rpm sudo yum -y install foreman-installer 

che ne risulta:

 Error: Package: rubygem-foreman_api-0.1.11-1.el6.noarch (foreman) Requires: rubygem(rest-client) >= 1.6.1 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodesgest 

I suggerimenti sembrano inutili (–skip-broken installa tutte le dependencies ma il responsabile / burattino). Ho finito qui e ho provato a installare il repository (dopo aver rimosso il vecchio)

 sudo yum -y remove epel-release sudo yum -y install http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm 

ora di nuovo, quello che ho provato:

 sudo -y update sudo -y install foreman-installer 

risulta nello stesso errore. Installazione senza un precedente aggiornamento è ansible (anche se yum si lamenta di chiavi pubbliche) e risulta nel seguente errore:

 [ec2-user@hostname ~]$ foreman-installer /usr/share/ruby/vendor_ruby/2.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- highline/import (LoadError) from /usr/share/ruby/vendor_ruby/2.0/rubygems/core_ext/kernel_require.rb:55:in `require' from /usr/sbin/foreman-installer:3:in `<main>' 

Avevo problemi simili mentre cercavo di installare passeggeri e alla fine si arrese. Suppongo che questo accada a causa della conflittuale versione ruby, quindi:

 [root@hostname puppet]# ruby --version ruby 2.0.0p451 (2014-02-24 revision 45167) [x86_64-linux] [root@hostname puppet]# gem --version 2.0.14 [root@hostname puppet]# ls /usr/bin | grep ruby ruby ruby1.8 ruby2.0 [root@hostname puppet]# ls /usr/bin | grep gem gem gem2.0 

Qualcuno ha eseguito gli stessi problemi? Come posso risolvere questo problema?

Grazie in anticipo e grazie per aver letto tutto questo!

  • ambiente gem e $ GEM_PATH non si aggiorna quando si utilizza rvm
  • Test di Rubino sul server debian stabile
  • Imansible distribuire un'applicazione di rotaie usando il codice eb cli
  • omnibus ha installato gli chef e i rvm
  • Come utilizzare il monit per assicurarsi che solo una istanza di process sia in esecuzione
  • È ansible utilizzare script personalizzati per l'authentication con PAM?
  • Come fare Chef-Server utilizzare Ruby 1.9 su Ubuntu?
  • Ruby installato su Ubuntu 10.10 lento su una macchina, ma non altro
  • 4 Solutions collect form web for “Installazione di Foreman su istanza amazon ec2”

    I pacchetti per Red Hat Enterprise Linux ei suoi cloni non sono compatibili con Amazon Linux. Dovresti trovare un modo diverso per installare Foreman o preferibilmente una diversa distribuzione Linux (Amazon Linux ha molte questioni che lo rendono generalmente inadatto per quasi tutto).

    Da quando ho passato molto tempo con il burattino su amazon recentemente ho voluto aggiornare questo.

    Poiché la versione del burattino su amazon linux apparentemente non è compatibile con l'installazione predefinita di ruby2.0, dovrai installare roba ruby1.8 mancante e collegarvi ai file corretti. Questo dovrebbe fare il trucco:

    preparazione per l'installazione:

     if ! yum repolist | grep -q puppetlabs; then echo "..enabling puppet repository.." # https://tickets.puppetlabs.com/browse/PUP-2132 echo -e "[main]\nenabled = 0" > /etc/yum/pluginconf.d/priorities.conf rpm --quiet -ivh http://yum.puppetlabs.com/el/6/products/x86_64/puppetlabs-release-6-10.noarch.rpm fi echo "..updating.." yum -y --quiet clean all yum -y --quiet update if readlink /etc/alternatives/ruby | grep -q "ruby2\.0" then echo "..making ruby1.8 default.." ln -sf /usr/bin/ruby1.8 /etc/alternatives/ruby fi if readlink /etc/alternatives/gem | grep -q "gem2\.0" then echo "..making gem1.8 default.." ln -sf /usr/bin/gem1.8 /etc/alternatives/gem fi 

    e installare il burattino con apache:

     PACKAGE="puppet" #PACKAGE="puppet-server" echo "..installing "$PACKAGE" and requirements.." yum -y --quiet install "$PACKAGE" rubygem18-json 

    e infine il passeggero:

     echo "..installing passenger and requirements.." yum -y install httpd httpd-devel mod_ssl ruby18-devel rubygems gcc gcc-c++ curl-devel openssl-devel zlib-devel gem install rack passenger passenger-install-apache2-module --auto 

    Non dimenticare di fare le cose usuali (config.ru e la config vhost per apache) e poi tutto dovrebbe funzionare. Non ho provato questo con il responsabile perché abbiamo scelto di non usarlo, tuttavia potrebbe essere ansible e se così dovrebbe funzionare abbastanza simili.

    Sono stato in grado di installare il responsabile in Amazon Linux, utilizzando il periferico-installer che installa anche il proxy foreman.

    Il burattina e il caposquadra di Becaause usano ruby1.8 e amazon linux per impostazione predefinita usa 2.0

    • echo -e "[principale] \ nenabled = 0"> /etc/yum/pluginconf.d/priorities.conf
    • yum installare ruby18
    • yum installare rubygems18
    • alternative –config ruby ​​=> scegli ruby1.8

    Successivamente, il pacchetto scl-utils (versione 20120229) in epel per non ha questo file / usr / bin / scl_source. Hai bisogno di questa versione 20120927. Ho trovato qui:

    Avanti è necessario il pacchetto ipmitool. Ho usato yum downloader su una casella centos e installato

    • yum localinstall ipmitool-1.8.15-2.el6.x86_64.rpm.

    Dopo che il periferico-installatore -i finito con successo.

    Ho avuto lo stesso errore su un sistema CentOS 6. Risulta che ho bisogno di installare un repository aggiuntivo come descritto nella guida di installazione per il responsabile:

    http://theforeman.org/manuals/1.5/index.html#3.3.1RPMPackages

    Tutti i RHEL e i derivati ​​richiedono Red Hat Software Collections (RHSCL) 1.0 o la ricostruzione, ad es. Software Collection per CentOS. RHSCL è disponibile per i clienti RHEL come repository separato o canale infantile. Ulteriori informazioni su Software Collections per CentOS sono disponibili qui e per Scientific Linux è disponibile qui.

    Suppongo che tu dovresti fare qualcosa di simile nell'istanza di AWS.

    Suggerimenti per Linux e Windows Server, quali Ubuntu, Centos, Apache, Nginx, Debian e argomenti di rete.