Le dependencies rotte su CentOS 6.4: possono installare nodejs ma non npm

Sto utilizzando un nuovo CentOS 6.4 installato (x86-64) con il repository EPEL.

$ yum install nodejs ... $ node -v v0.10.5 

Finora, così buono, ma quando provo a installare npm , npm questo messaggio di errore:

 $ yum install npm Loaded plugins: fastestmirror, refresh-packagekit, security Loading mirror speeds from cached hostfile * base: ftp.halifax.rwth-aachen.de * epel: mirror.fraunhofer.de * extras: centos.psw.net * updates: centos.psw.net Setting up Install Process Resolving Dependencies --> Running transaction check ---> Package npm.noarch 0:1.2.17-5.el6 will be installed --> Processing Dependency: npm(which) < 2 for package: npm-1.2.17-5.el6.noarch --> Processing Dependency: npm(uid-number) < 1 for package: npm-1.2.17-5.el6.noarch --> Processing Dependency: npm(tar) < 0.2 for package: npm-1.2.17-5.el6.noarch --> Processing Dependency: npm(slide) < 2 for package: npm-1.2.17-5.el6.noarch --> Processing Dependency: npm(semver) < 1.2 for package: npm-1.2.17-5.el6.noarch ... (skipped) ... --> Finished Dependency Resolution Error: Package: nodejs-npmlog-0.0.2-4.el6.noarch (epel) Requires: npm(ansi) < 0.2 Error: Package: npm-1.2.17-5.el6.noarch (epel) Requires: npm(ansi) < 0.2 Error: Package: nodejs-npmlog-0.0.2-4.el6.noarch (epel) Requires: npm(ansi) >= 0.1.2 Error: Package: npm-1.2.17-5.el6.noarch (epel) Requires: npm(ansi) >= 0.1.2 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodesgest 

L'output completo è piuttosto grande: http://pastebin.com/raw.php?i=Ce3ZJsEB

Cosa dovrei fare? La soluzione alternativa --skip-broken non sembra essere la soluzione giusta.

Ecco la produzione di yum repolist :

 Loaded plugins: fastestmirror, refresh-packagekit, security Determining fastest mirrors * base: centos.copahost.com * epel: mirror.fraunhofer.de * extras: ftp-stud.fht-esslingen.de * updates: centos.copahost.com repo id repo name status base CentOS-6 - Base 6,381 epel Extra Packages for Enterprise Linux 6 - x86_64 8,909 extras CentOS-6 - Extras 12 updates CentOS-6 - Updates 727 repolist: 16,029 

  • Come aggiornare OpenSSL su CentOS 6.5 per proteggere contro i heartbleed?
  • Non in grado di installare mysql / mysql-server con yum in Centos 6.4 64bit
  • Come faccio a utilizzare RPM per installare GCC dal mio supporto di distribuzione CentOS?
  • Aggiornamento MySQL 5.5 a 5.6
  • Come installare la sezione 3 manpages per CentOS
  • centos yum aggiornare tutti i 68 server
  • Installare xdebug per php 5.3.17 su centos 6.3 (finale)
  • Perché ho un file .rpmnew dopo un aggiornamento?
  • One Solution collect form web for “Le dependencies rotte su CentOS 6.4: possono installare nodejs ma non npm”

    Il pacchetto nodejs-ansi da EPEL ( nodejs-ansi-0.1.2-7.el6.noarch ) è interrotto.

    Provare:

     wget http://kojipkgs.fedoraproject.org//packages/nodejs-ansi/0.1.2/7.el6.1/noarch/nodejs-ansi-0.1.2-7.el6.1.noarch.rpm yum --enablerepo="epel" install npm ./nodejs-ansi-0.1.2-7.el6.1.noarch.rpm 

    Soluzione fondata su #epel all'indirizzo irc.freenode.net.

    Vedi anche: http://pastebin.com/mqFqRqUp linea 28

    Suggerimenti per Linux e Windows Server, quali Ubuntu, Centos, Apache, Nginx, Debian e argomenti di rete.