Nessun dispositivo di networking loopback dopo l'aggiornamento della protezione ubuntu 12.04

Ho avuto Ubuntu 12.04 su un server per gli ultimi mesi, con tutto funzionante bene. Ieri sera ho fatto un aptitude update && aptitude safe-upgrade per portre in tutte le ultime modifiche di sicurezza e ora quando avvia il server non viene creato nessun dispositivo.

Riport correttamente le interfacce ethernet fisiche e posso ping dentro e fuori dalla macchina su quelle interfacce, ma niente può connettersi a niente su localhost o 127.0.0.1 .

ifconfig elenca solo eth0 e eth1 .

Niente affatto.

Ecco il contenuto di / etc / network / interfaces:

 # The loopback network interface auto lo iface lo inet loopback # The primary network interface auto eth0 #NetworkManager#iface eth0 inet dhcp 

Dove dovrei cercare di diagnosticare e correggere?

Grazie!

  • "Nessuna informazione sulla versione disponibile" - Dopo l'installazione di Postgres
  • Ubuntu 12.04 - HP ProLiant DL380 G4 - Carica Maxes Out / Non risponde
  • Esegui fail2ban senza divieto
  • Come faccio a sapere quale programma di posta elettronica è installato / invio di email?
  • Bassa nello spazio in / run
  • php-mysqlnd o php-mysql
  • Utilizzo di un certificato SSL di GoDaddy con Virtualmin (Webmin)
  • Evitare il controllo apt-da mangiare tutta la mia memory
  • 2 Solutions collect form web for “Nessun dispositivo di networking loopback dopo l'aggiornamento della protezione ubuntu 12.04”

    Ho avuto un problema simile.

    Il mio lo non è stato avviato automaticamente all'avvio (dopo aver distriggersto IPv6 tramite sysctl e riavviando il server).

    La mia prima soluzione era iniziare manualmente con ifup --force lo . Ma dopo che ho dovuto riavviare la maggior parte dei miei servizi in quanto non funzionavano correttamente senza loopback.

    Infine questo vecchio forum mi ha aiutato a scoprire la soluzione corretta e permanente:

    1. sudo rm -rf /var/run/network/*
    2. sudo reboot

    (A quanto pare c'era un vecchio file .lock che impediva che il loopback iniziasse correttamente.)

    Se lo può essere portto manualmente con ifup lo ma non viene ifup lo automaticamente, si dovrebbe essere in grado di mettere il command ifup lo in /etc/rc.local modo che inizierà each avvio. Non una soluzione elegante, ma dovrebbe essere una soluzione permanente.

    Suggerimenti per Linux e Windows Server, quali Ubuntu, Centos, Apache, Nginx, Debian e argomenti di rete.