Problema di identity framework; del pool di applicazioni di IIS

Ho un problema con un pool di identity framework; su un nuovo server IIS.

Ecco il mio text del visualizzatore events:

Event Type: Warning Event Source: W3SVC Event Category: None Event ID: 1021 Date: 6/12/2009 Time: 1:44:50 PM User: N/A Computer: <scrubbed> Description: The identity of application pool, '<scrubbed>' is invalid. If it remains invalid when the first request for the application pool is processed, the application pool will be disabled. The data field contains the error number. For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp. Data: 0000: 69 05 07 80 i..? 

Google suggerisce che sia qualcosa a che fare con l'utente del pool di app che ho impostato nella scheda "Identity". I problemi più comuni sono:

  1. Impostazione della password errata
  2. Non aggiungere l'utente al gruppo IIS_WPG

Ho provato e riprovato entrambi (e ho riavviato il servizio IIS), e non sembra che sia stato risolto. Quali altre cose dovrei cercare.

FWIW, l'utente di identity framework; è un utente di dominio (non locale). Questa stessa configuration funziona bene in un altro server / setup (supposto identico).

  • Impostazioni avanzate di IIS7.5 Pool di applicazioni - il report di WAS supera le impostazioni del limite di lavoro
  • Distriggersre .net completamente in un pool di applicazioni IIS6
  • Riscaldamento automatico di un pool di applicazioni di IIS?
  • I pool di applicazioni sono generalmente più grandi in IIS 8.5 vs IIS 7.5?
  • Autorizzazioni di identity framework; di pool di applicazioni IIS 6
  • Il pool di applicazioni viene arrestato quando il sito è ad alto traffico
  • È l'attributo serviceAutoStartProvider necessario per avviare automaticamente un'applicazione ASP.NET?
  • Identificare quale pool di applicazioni utilizza CPU / memory
  • 4 Solutions collect form web for “Problema di identity framework; del pool di applicazioni di IIS”

    Grazie a MattB, questo thread di Overflow Stack mi ha portto alla risposta giusta (per me).

    Ho eseguito il seguente command (da C: \ WINDOWS \ Microsoft.NET \ Framework \ v2.0.50727):

     aspnet_regiis.exe -GA domain\username 

    … where dominio \ username era il nome utente dominio (nel formato standard di Windows) dell'utente che stavo usando per l'identity framework; del pool di app.

    Dall'opzione aspnet_regiis, l'opzione -GA fa:

     Grant the specified user or group access to the IIS metabase and other directories used by ASP.NET. 

    Non so perché questo non sia stato fatto automaticamente su questo server (come non ho mai dovuto fare in passato).

    Un tiro al buio, ma forse l'account di dominio che hai configurato per l'identity framework; di Pool App è bloccato?

    Provare a fornire anche l'account "Accesso come servizio". Ecco una domanda molto simile dalla overflow dello stack.

    Se si utilizza IIS6, con Metabase Explorer (nel kit di risorse ), è ansible effettuare le seguenti operazioni:

    • accedi a / LM / W3SVC / AppPools / MyAppPool
    • abilita "Visualizza / protetti dati"
    • (se necessario) abilitare "Visualizza / dati ereditati"

    Ora guarda il WAMUserName e WAMUserPass. È ansible provare a eseguire processi come tale utente:

     runas /user:myuser cmd.exe 

    Se ciò non funziona, dovresti essere più vicino alla risposta.

    Suggerimenti per Linux e Windows Server, quali Ubuntu, Centos, Apache, Nginx, Debian e argomenti di rete.