Problema di routing Juniper EX3300

Il routing sul mio Juniper EX3300 non sembra funzionare. Il gateway del mio ISP è a xx.xx.xx.xx E ho la seguente nella configuration:

routing-options { static { route 0.0.0.0/0 { next-hop xx.xx.xx.xx; retain; } } } 

Posso ping al gateway dell'ISP dall'interruttore. Tuttavia, non posso fare ping a nessun altro IP. Quando faccio un traceroute (all'indirizzo IP di Google.com). Questo è quello che ottengo:

 traceroute to 74.125.224.69 (74.125.224.69), 30 hops max, 40 byte packets traceroute: sendto: No route to host 1 traceroute: wrote 74.125.224.69 40 chars, ret=-1 *traceroute: sendto: No route to host 

Devo triggersre tutti i protocolli? Immagino che questo sia ovvio, ma sono un po 'nuovo a Junos.

Aggiornamento: Questa è l'output dalle show interfaces terse | match inet show interfaces terse | match inet :

 bme0.32768 up up inet 128.0.0.1/2 jsrv.1 up up inet 128.0.0.127/2 vlan.0 up up inet 10.0.1.1/24 vlan.1 up up inet xx.xx.xx.110/30 

e questa è l'output da: show route forwarding-table :

 Routing table: default.inet Internet: Destination Type RtRef Next hop Type Index NhRef Netif default perm 0 rjct 36 1 0.0.0.0/32 perm 0 dscd 34 1 10.0.1.0/24 intf 0 rslv 1321 1 vlan.0 10.0.1.0/32 dest 0 10.0.1.0 recv 1319 1 vlan.0 10.0.1.1/32 intf 0 10.0.1.1 locl 1320 2 10.0.1.1/32 dest 0 10.0.1.1 locl 1320 2 10.0.1.3/32 dest 1 0:25:90:63:26:53 ucst 1331 2 vlan.0 10.0.1.255/32 dest 0 10.0.1.255 bcst 1318 1 vlan.0 

    2 Solutions collect form web for “Problema di routing Juniper EX3300”

    Beh, posso vedere che questo è dovuto al fatto che il tuo sistema non ha installato un path predefinito, per qualche motivo. Confronta la tua tabella di inoltro con la mia:

     > show route forwarding-table Routing table: default.inet Internet: Destination Type RtRef Next hop Type Index NhRef Netif default user 2 0:13:5f:3:af:8f ucst 580 5 fe-0/0/0.0 default perm 0 rjct 36 1 0.0.0.0/32 perm 0 dscd 34 1 

    Notare che l' default è elencata due volte per me. Uno con il tipo ucst e una volta con rjct e il tuo ha solo una linea con rjct . Quel rifiuto è il motivo per cui non stai vedendo no route to host .

    La mia migliore ipotesi è che il daemon di routing deve essere riavviato. È ansible provare a distriggersre le opzioni di instradamento e commutare, quindi ritriggersrla. Non credo neppure che tu abbia bisogno della properties; di retain sul next-hop . È inutile nella maggior parte delle situazioni normali.

    Un modo sicuro per farlo in modo efficace se l'unità è remota è distriggersrla e quindi rilasciare il commit confirmed 5 . Questo ripristinerà automaticamente la configuration dopo 5 minuti.

    Ho anche incontrato momentjs in cui wherevo riavviare il dispositivo per get la tabella di routing per risolvere correttamente, quindi se non funziona dopo la procedura di cui sopra, allora prova a riavviare.

    Naturalmente, questo suppone che non abbia usato il next-hop . Poiché non l'hai elencato, non posso dire per certo, ma secondo la tabella di routing e la configuration dell'interface, il next-hop dovrebbe essere [REDACTED] . Se ciò non corrisponde a quello che hai, allora c'è il tuo problema.

    Quando si utilizza la politica di routing, verificare se il prossimo hop è nella tabella ARP.

    ps. solo indovinare, ma fondamentalmente questo potrebbe essere il caso.

      Suggerimenti per Linux e Windows Server, quali Ubuntu, Centos, Apache, Nginx, Debian e argomenti di rete.