scilinux6 (rhel6) perl path domanda

Lavorare su SL6.

[CODICE] $ cat / etc / redhat-release Scientific Linux versione 6.0 (Carbon) $ uname -an Linux bigbox.em.local 2.6.32-131.6.1.el6.x86_64 # 1 SMP gio giu 12 17:14:50 CDT 2011 x86_64 x86_64 x86_64 GNU / Linux

  • Posso impostare Repo Fedora o Centos in RHEL6?
  • Come installare jq su RHEL6.5
  • Php pdo_dblib - non riesce a trovare / non riesce a caricare freetds
  • IPTABLES - Limite di un determinato IP in entrata
  • Il gateway predefinito è in una substring diversa. Come configurare in RHEL6.2
  • Alternativa leggera a R per RHEL?
  • qual è il modo giusto per risolvere quanto segue:

    CODICE $ perl Build.PL Imansible individuare Module / Build.pm in @INC (@INC contiene: / usr / local / lib64 / perl5 / usr / local / condivisione / perl5 / usr / lib64 / perl5 / vendor_perl / usr / condividere / perl5 / vendor_perl / usr / lib64 / perl5 / usr / share / perl5.) alla linea Build.PL 4. BEGIN non rioutput – la compilazione è stata interrotta alla row Build.PL 4.

    Ho scoperto quanto segue:

    CODICE

    $ rpm -qa | grep Costruisci perl-ExtUtils-CBuilder-0.27-119.el6.x86_64 perl-Module-Build-0.3607-1.el5.rf.noarch

    quindi sembra che sia lì.

    CODICE

    $ sudo updatedb $ localizza Build.pm /usr/lib/perl5/vendor_perl/5.8.8/Module/Build.pm

    Quello che non sembra sia nel @INC. Potrei fare un symlink, o semplicemente mettere 5.8.8 nel $ INC, ma poi ciò avrebbe sbagliato each futuro aggiornamento, per non parlare di qualunque cosa si romperà.

    Grazie in anticipo!

  • Perl versione predefinita
  • SELinux impedisce allo script CGI Perl di accedere alle librerie Oracle
  • Mod Perl su RHEL 7
  • Crittografia password LDAP (attributo userPassword)
  • Accesso MSSQL da Perl
  • Esegui script CGI di Perl su CentOS 7 con Apache / Httpd
  • One Solution collect form web for “scilinux6 (rhel6) perl path domanda”

    Questo pacchetto Module :: Build è da 'el5' che significa Scientific Linux versione 5.0, appartiene a una versione precedente di Scientific Linux e Perl: 5.8.x mentre SL6 ha Perl 5.10.x.

    Verifica se puoi installare una versione recente dai repository:

    yum install 'perl(Module::Build)' 

    se ciò non funziona, potrebbe essere necessario controllare la configuration del repository del sistema. Dopo questo, avrai la versione installata, nel tuo path, come ci si aspetterebbe.

    Suggerimenti per Linux e Windows Server, quali Ubuntu, Centos, Apache, Nginx, Debian e argomenti di rete.